Rheem Furnace – not lighting

______________________________________________________________________ I have a Rheem Criterion II Model RGPH- It is not firing. When the thermostat is turned on the furnace cycles, the heating element turns real red and the gas valves open but the burners never come on. What can be the problem? Replies: acefurnacefixer “Re(1):Rheem Furnace – not lighting” , posted Sun 20 Nov 18:11 ______________________________________________________________________ If you are 100% sure that you have gas to the unit and 24 vac present when you hear the click……then you have a bad gas control valve. Yes! I CAN fix that! mbk3 “Re(1):Rheem Furnace – not lighting” , posted Sun 20 Nov 16:37 ______________________________________________________________________ Is the gas on? Sounds like a dumb question,however have seen many times. Line valve on..gas control on position.. May be spider nest in burner orifice jskills50 “Rheem Furnace – not lighting” , posted Sun 20 Nov 16:39 ______________________________________________________________________ jskills50 “Rheem Furnace – not lighting” , posted Sun 20 Nov 16:41 ______________________________________________________________________ Yes, the gas is on. You can hear the gas valves open. I just replaced the heating element with a new so it comes on bright red but the burners will not light. fitter597 “Re(1):Rheem Furnace – not lighting” , posted Sun 20 Nov 17:01 ______________________________________________________________________ there is an outlet pressure tap port for gas pressure in and out on the main gas control valve, it is an allen screw take them off one at a time and see if you have gas to the valve first and from the gas valve,when you try to start it. maybe your gas control is bad tinner73 “Re(2):Rheem Furnace – not lighting” , posted Sun 20 Nov 19:25 ______________________________________________________________________ did you pay the gas bill? union trained in Chicago

Comments are closed.