York Furnace — Burner doesn’t light properly

09:50 ______________________________________________________________________ I have a 10-year old York furnace. The burner does not light properly. The draft motor starts and runs OK. The hot surface ignitor glows for a few seconds and the gas valve is opened and the first jet lights. Since the other jets do not light, the flame sensor doesn’t sense the flame from the last jet, the gas valve is shut off. It rests for a minute with the draft motor running and then tries lighting again. Sometimes all the jets light on the second or third try. Usually they do not and it goes straight into lock-out. What may be causing the cross-lighting problem? Is this something I can fix myself, or do I need to call a service tech? Thanks. Brian Brian Replies: Wolfe “Re(1):York Furnace — Burner doesn’t light pr” , posted Tue 26 Oct 19:08 ______________________________________________________________________ The burners need to be cleaned. Pull them out and run a wire brush over the ends and the crossovers (skinny sections). HVAC Pro “Re(2):York Furnace — Burner doesn’t light pr” , posted Tue 26 Oct 19:15 ______________________________________________________________________ Call for professional service before you lose your eyebrows! : ) james mo “Re(3):York Furnace — Burner doesn’t light pr” , posted Tue 26 Oct 23:04 ______________________________________________________________________ Removing the burners from that unit is not as easy as it looks. All of the burners come out as an assembly and this takes some time and experience. Call a technician to do this. Another day in paradise

Comments are closed.